April 2010

QA Studio can help you monitor the raw milk supply coming into your facility.

There is a producer database in QA Studio. You can easily import producer information and
maintain that information.

In addition to tracking the producers that you are receiving, you can track if they are rBST free. If
your facility only receives rBST free milk, QA Studio can alert the user if a producer is added that
has not been identified as being rBST free. To be alerted of rBST free status, this feature will need
to be activated in Raw Defaults (details below).

rBST Free: BST or Bovine Somatotropin is a naturally occurring protein hormone produced by cows. rBST or Recombinant Bovine Somatotropin is
synthesized in large quantities (artificial growth hormone) and some dairymen may give to cows to increase milk yield. Some milk processing plants
only accept milk from producers that have signed an affidavit stating they do not use rBST.

If you receive an updated producer list routinely, that list of information can be imported into the QA Studio Producer Window, including if the producer
has a signed affidavit stating the raw milk is rBST free.

Producer Window: Go to Raw Program Menu > Producer Window.

Requirements for Importing Producer Information: Go to Producer Processes Menu > Import Producers > Click on Import
Requirements. A box will pop up and give you information on the requirements. The information will need to be sequenced in the columns as listed
below and then the file will need to be saved as a Tab Delimited text file.

M Producer Import Winow

Elamatpovn

Import file needs to be a Tab Delimted text file.

Data requiremments: Producer Number, Producer Name, Affidavit Present (boolean)), Affidavit Date, State, Supplier, Contact, Address and BTU#.

The arder of the infarmation in the file:

s Producer Number
s Producer Name
o Affidavit (Boolean) Must be “Yes” or “No”
«  Affidavit Date
. State
+  Supplier
* Contact Person
o Address.
s  BTU Number

Monthly List of rBST Free Raw Milk

Number Name of Producer rBST Free  Affidavit Date  State  Supplier Contact Address BTU
431 Aand B Dairy Farm  Yes 1MNo CA  ABCDairyF arm Mr. John Farmer 1234 Dairy Way, Anywhere, CA 12345 06-123
5432 C and D Dairy Farm  Yes nno MY ABCDairyFarm Mrg, Jane Doe 4567 Dairy Road, Anywhere, NV 45678 31-123
6543 Cows R Us Dairy es N0 CA  ABCDainFarm Betsie Holstein 8765 Cow Way, Farm City, CA 23456  06-123
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QA Studio: Raw Milk Producer Window - rBST Free Producers April 2010

To save the file as a Tab Delimited Text file: Once the
producer information is in the correct columns in the Excel file; go to Template pd., e
FILE > SAVE AS > FILES OF TYPE > Select Text (Tab delimited) Unicode Text (*.08)
(*.txt) as seen in the example to the right. You will also need to enter a Microsoft Excel 5.0/95 Workbook (*.xs)

File name. For example: MayrBSTFreeL.ist.txt. (The extension will be File name: Microsoft Excel ‘??72002?5-0!95 Wiorkbook (*.xds)
txt). CSY (Comma delimited) (*.csv)

Files of type: |Excel 2007 Workbook. (*.xsx)

Once file is ready (columns of information in order and R e mur G S '

saved as a text file): The information is ready to be loaded into the .

. . _ #a []
QA Studio Producer Import window. Go to the Raw Program Menu > [ oxtee ] o
Producer Window > Click Load Data > Select the rBST free file saved Poase R
as the txt file > Click OK.

Select import file

Lookinc | [} Dedicp w -3 N dld
Mame - o Ske Type
) [£) rBSThrecEsportExample. bt 148 Text Document C

Producer Information will load into the Producer Import window: Review the information to make sure the proper information
is in the correct columns.

M Producer Import Winow

[ctesn tpOute
Producar 8 Name Alfidavit Effective State Supphet Contact Address Add1 A City State Zip | BTUB  Import Stabus

NUMBER Name OF Producer | i i Supplier Contact | Address | Address |BTU

431 AAnd B Dary Fam (YES  |01A01A0 |CA | ABCDainFarn | M. John Farmer | 1234 Dairy Way, .. | 1234 Daiy'Way | |Argwhere CA 12306123
5432 CAnd D Dairy Faemn (YES (02401710 NV ABCDainFam Mis. Jane Doe | 4367 Dairy Road, . 4567 Daily Road | (Argwhese [NV [456...131-123
E543 Cow: B Us Dary  |YES 03410 |CA | ABCDainF aim Betse Holstein | 8785 Cow 'Way, F...| 8765 Cow 'Way | |FarenCity |CA 234 |08123

It is important to make sure the Supplier matches a Supplier in the Supplier Window: Before importing the producer information,
make sure the supplier matches a supplier that is already in the Raw Supplier Window. If there is a new supplier (not in the Raw Supplier Window), first
enter the new supplier name in the Raw Supplier Window. Go to Raw Program Menu > Supplier Window > Add > Enter the new supplier name > Click
OK to save. If the supplier doesn't match exactly, it can be fixed in the file before loading in the Raw Producer Window OR the producer information can
be fixed after loading into the Producer Window but BEFORE importing by simply selecting a line and double clicking. An Import Row Adjustments
box will pop up and allow you to change the supplier to match one that is already in the Supplier Window. It will then ask if you want to change all
producers with that specific supplier to the selected supplier name chosen from the drop down list. If you click yes, all the supplier names that match that
particular supplier will be changed to name that was selected from the pull down box (list of names of suppliers already in Supplier Window).

Flewtn s

Name: Alidavit Effective State Suppber  Contact Address Add] Add2 Ciy StleZp  BTUR Import Status

Narme Of Producer Supphet Contact |Address Addiess BTU

AAndBDasyFam |YES  |01/01/10 [CA |ABCDsigF.|Mr. John Far.. (1238 DainyWay, . |1234 DasyWay Angwhere |CA 12345 06123

CAnd D Dairy Farm | YE! RN - . Gl Bt Angwhere [NV 45678 |31-123 H

ERLICEERNE m Import Row Adjustments FamCly |CA 2456 (06123 When the |mp0rt Row Adjustments

Producer * (4321

box is open: You can make any other
adjustments needed for that specific producer
that was highlighted. Click OK.

Name: |4 And & Dairy Farm

Arfidavit: [] Affidavit on File
Effective Date: |01/01/10

Affidevit State: |CA /
= supplier: [ABCOsIryFarm .
Contact: [Hr. John Farmer [RACETE

Co-OpA
Address: | 1234 Dairy Way, Anywhere, CA|Inhouse

00 you wank 5 change +8 ABCDSR)Farm’ entries & "ABDwY 7

BTU: [06-123

P concel| o

Once you have reviewed all the producer information and it is correct, click Import Data (located at the bottom left hand corner of window). Note: If the
column heading has a description such as Name, that will come over also with the import. Either eliminate the column heading in the file before loading
or delete that particular record after importing. Highlight the record once it is in the Producer window and click delete.
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Producer Information will show in the Producer Window: The newly imported producer information will be in the Producer Window and
will have the imported date documented.

M Producer Window r.—|E|E|
Producer |Bloc.| Name Internal Contact Default BTU | Effective Updated Imported
47777 Hery Milker i i [12/12/07{05/06/10 11:20 | -l
4555 Holstein Farms | i l07/07/07
45545 ; H
42555 425 Dairy wWay  VES  iMr. Milk Producer :00-456 01/01/08 /
425 i 11-123 05706/ 10 {05/06/10 11:11
372123 | |John Doe Farms i |0B8/08/08
A And B Deiry Fe.. Mr. John Farmer 06-123 Q1701710 05/06/10 1505 0S5/06/10 1505
6543 Cows R Us Dairy |Betsie Holstein [06-123 103/01/10105/06/10 1505 [05/06/10 1505

5432 C And D Dairy Fo.. | EHFS Jane Doe 31-123 5024"0”'10 05/06/10 1505 [0S/06/10 1505

Turn on the Alert rBST Free Producer Status: To be alerted
if the producer in the QA Studio database has the rBST Free Affidavit
checked or not, go to Raw Program Menu > Raw Defaults > rBST Free
tab on click EDIT and check Alert on Producers rBST Free Affidavit
Status. If this feature is turned on it is very important that the QA Studio
producer database is kept up to date and with the correct producer
information. It is also critical that the QA Studio user entering the
producer numbers into QA Studio confirms that the producer numbers
were scanned or entered correctly. The QA Studio user entering the data
should be informed of the warning boxes and should read and check with
supervisor and follow your company policy. Note: Enter in your own
messages for the pop up boxes if desired. Otherwise there are default
messages that will pop up.

M RAW Defaults

[#]4bert on Producers rBST Free Affidavit Status

‘ez wsing this featuee il is calical bo maintain the: Producer and the Suppler window with th seilings and inf

Ithmaibdmlh pesson entering of scanning the producers into DA Studio to confiim the producers were scanned of entesed
comectly.

uryy ispue Found veth this feabuee shoulkd be brought Lo the altention of the Dl Shudko support team immedialely 2o conective action
can be taken

The user shal ot bold 04 Studo Rsble foe ary isuss that aise wing e lestue.

Mo Cumert (BST Fres Affidavit Meseages: The rEST Free Affiduwit on Tike 15 not current. Chesk with sugsrvisor.

Mo (BST Free Affidavit Message: | There i KO rBST Free Affidavit on file for thie produser. Check with susrvissr

Producer Mol in Databare Mestags The Preduter snbered 15 not in the dutlasase. Chiok with supsrvisor.

kmport Details | Tech I Change Manapement I COA / Manifest FEST Fret IDribations
Gemeral Wformation | Data Entry Defwalts | Screen Colors & Seftings | Antibiotic 1| Antibiotio 2 |_Regort verauits ] CIF Specs.

(= o ]

Information not Imported or Updated: If a producer was not
imported or updated, you will be alerted when entering that producer
number into the Raw Product window. In the example to the right:
Producer 47777 was not updated or imported during the last import.

™ Producer Window
B A B

Bdd Edc  Delers

Producer Bloc... Name Internal Contact Default BTU Effective Updated Imported l

| 42555 | |42% Dairy Wey  [VES  [Kir. Hilk Producer [00-456  [01/01/08 | | -

4321 |& &nd B Dairy Fa. 0101410 05706710

43543 |

4555 |Halstein Farms | 07/07/07
Hary Hilker [E 7

= T FEST Fre Datads
roducer Number Cert on File? [¥]rBST Fres Affidavit
Default BTU: Effective: [12/12/07
Internal Froducer: [] -

- Qrgank: Detads
Name: |Mary Milke Cert on Fiter [
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QA Studio: Raw Milk Producer Window - rBST Free Producers

Information not Current: A warning box will pop up alerting the
QA Studio User the rBST free certificate is not current. To make a record

current, go to the Raw Producer window click EDIT and OK. Even if no Producer Window.

April 2010

rBST Free Certificate Not on File: A warning box will pop up
alerting the QA Studio User the rBST free certificate is not on file in the

changes are made the record will assume it has up to date information.

D: Silo 2: Producer(s):

v ¥ 47777

Producer: "47777 Mary Miker®

The rBST Free Affidavit on file is not current. Check with supervisor.

Producer not in database: A warning box will pop up alerting the
QA Studio that the producer is not in the QA Studio producer database. If
the producer is added to the database at this time, it will not be marked as
rBST Free and a warning box will alert you to that fact. If you obtain the
rBST free affidavit and other details for that particular producer, then go
to the Producer Window click Edit and enter the information. If rBST
Free, then click the check box and enter the rBST Free Date.

Producer Field: The Producer field now also shows the name of the
dairy. If you add a producer that is already in the QA Studio producer
database with a producer name, it will show up when adding the producers
in the Raw Product Window. Note: the tank at the dairy farm can be added
also, simply put a dash behind the producer number to indicate the tank at

FBST Free Detais
Cert on File? []
Effective

T Free Affidavit

Producer: 35435 "

There is NO rBST Free Affidavit on file for this producer. Check with supervisor,

Lo ]

‘u: Silo 2: Producer(s):
v v 86655443

"86655443" The Producer entered is not in the database. Check with supervisor.

m Producers

Producer Hame
# And B Dairy Farm

oy 43211

the dairy.

rBST Free field: When entering one or
more producers in the Raw Product Window
(Producer field), and all the producers are
marked as rBST Free in the Producer
Window then the rBST Free box will
automatically say YES. If one or more of the
producers entered are not rBST Free as
indicated in the Producer Window, then the

box will not auto-fill.

Silo 2: Producer{s):
v v 4321-1,4321-2,6545- 1

Lot # ‘\

PO/Ref =
Tamg: LOAD =

Oder: 7o 00 -

Appearonce: / Mok
rUST Frae. YES ]
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Cows B Us Dairy

g

4321-2
w

QA Studio Warns Only: If you select to use this feature, and turn it on in the Raw Defaults,
rBST Free tab: the warning boxes will pop up to alert the QA Studio user that either the producer is not
in the database, or the producer’s rBST Free affidavit has not been updated with the last import or if
the producer doesn't have an rBST free affidavit checked in the Producer Window. QA Studio
alerts/warns the user to Check with the supervisor (or what is added in defaults by the QA Studio
person that maintains the program). QA Studio doesn't stop the user from entering data. Each company
using QA Studio to help monitor the incoming producers for rBST free affidavits should have
procedures in place to include (But not be limited to);

e  Routine monitoring and updating of the QA Studio Producer Window
e Notifying all QA Studio Users of the correct response when a warning box pops up

e  Alerting QA Studio support immediately of any issues that need to be addressed with this
feature
QA Studio helps warn of possible issues. Users will need to follow the company policy on accepting

rBST free loads or rejecting loads.

Benefit to QA Studio User: Monitor and track raw milk supply.

Dairy Technology workshop
September 27-30 2010

209 668-0600

HACCP Workshop
August 9-11 2010

Implementing SQF 2000 Systems
August 11-13 2010

==
frioclates

. www.qgastudio.com
authorized Dealer o QA Studlo



